PDA

Orijinalini görmek için tıklayınız : ÇÖZÜLDÜ Joomla 1.6 uyumlu tema joomla 1.7'de kullanılırsa ne olur?



Alaca
18-01-2012, 01:42
Joomla 1.6 uyumlu tema joomla 1.7'de kullanılırsa ne olur?

Localhostta şöyle hata veriyor. Peki gerçek hostta sorun çıkabilir mi?


Fatal error: Call to a member function getMessageQueue() on a non-object in C:\wamp\www\gray\templates\gray_v2\functions.php on line 194
Call Stack
# Time Memory Function Location
1 0.0004 386872 {main}( ) ..\index.php:0
2 0.1618 9351168 JSite->render( ) ..\index.php:49
3 0.1623 9351664 JDocumentHTML->parse( ) ..\application.php:253
4 0.1623 9351664 JDocumentHTML->_fetchTemplate( ) ..\html.php:378
5 0.1626 9352000 JDocumentHTML->_loadTemplate( ) ..\html.php:547
6 0.1633 9434376 require( 'C:\wamp\www\gray\templates\gray_v2\index.php' ) ..\html.php:488
7 0.1722 9590624 ArtxPage15->hasMessages( ) ..\index.php:82

Akar
18-01-2012, 02:02
Temanızda şu sayfaya göre bir kontrol ve düzeltme yapın:
Upgrading a Joomla 1.5 template to Joomla 1.6 - Joomla! Documentation (http://docs.joomla.org/Upgrading_a_Joomla_1.5_template_to_Joomla_1.6)

Başka bir şey gerekmez.

Alaca
19-01-2012, 00:21
Hocam orası 1.5'den 1.6 uyumu anlatılmıyor mu?

Ayrıca hangi kısımlarda ne yapılacağını tam anlayamadım. Kısaca anlatırsanız makbule geçer.

kaderebak
19-01-2012, 00:37
1,6 da çalışan bileşen tema vs. 1.7 de de sorunuz bir şekilde çalışıyor.. Benim bildiğim kadarı ile..

Alaca
19-01-2012, 06:39
Temayı 1.7 de normal hostta denediğimde şu hatayı alıyorum:


Fatal error: Call to a member function getMessageQueue() on a non-object in /hdd2/home2/nedemeli/public_html/templates/gray_v2/functions.php on line 194

Hata satırında ise bu kodlar var:

$messages = $mainframe->getMessageQueue();

Akar
19-01-2012, 07:37
1,6 da çalışan bileşen tema vs. 1.7 de de sorunuz bir şekilde çalışıyor.. Benim bildiğim kadarı ile..Temanın çalışması lazım normalde; diğer eklentiler 1.6 için kodlanmamışsa sorun olabilir.
Hocam orası 1.5'den 1.6 uyumu anlatılmıyor mu?

Ayrıca hangi kısımlarda ne yapılacağını tam anlayamadım. Kısaca anlatırsanız makbule geçer.
Temanın 1.6'da nasıl çalıştığını da anlayamadım aslında; çünkü bu function 194'ü 1.6 uyum sorununda veriyordu diye hatırlıyorum. Joomla 1.6 için uydurulmuş bile olsa bir tema Jooma 1.7 ile çalışır...çalışmıyorsa ben ona 1.6 teması olarak bakmadığımdan 1.5-1.7 tema yükseltme dokümanını vermek istemiştim.

Hazır yazdığım vardı bakayım, bulamazsam yeniden anlatırım.

Alaca
19-01-2012, 13:38
Hocam tema burada, bir de indirip göz atın olmazsa.

More Than 3100 Free Joomla CMS Templates - Gray V2 (http://www.joomla24.com/option,com_remository/Itemid,4/func,fileinfo/id,5241.html)

Ümit
19-01-2012, 14:21
$messages = $mainframe->getMessageQueue();

yerine

$messages = JFactory::getApplication()->getMessageQueue();

yazınca çalışıp çalışmadığına bakabilir misin?

Alaca
19-01-2012, 14:47
$messages = $mainframe->getMessageQueue();

yerine

$messages = JFactory::getApplication()->getMessageQueue();

yazınca çalışıp çalışmadığına bakabilir misin?

Hata kalktı teşekkürler. Bu temada sorun var mıdır sizce? Projeye bununla devam edip etmemekte kararsız kaldım.

Ümit
19-01-2012, 14:51
Tema yapımcısı tarafından artık güncellenmediği için kullanımı yeni sorunlara yol açabilir ve boşuna zaman kaybı yaşarsınız.

Akar
19-01-2012, 15:29
$messages = $mainframe->getMessageQueue();

yerine

$messages = JFactory::getApplication()->getMessageQueue();

yazınca çalışıp çalışmadığına bakabilir misin?Evet işte bu zaten aslında 1.6 temada olması gereken dzüeltme. Yani tema aslında 1.6 teması bile değilmiş. Sık sık değinmeye çalıştığım durum bu. Siz bir eklentiyi 1.6 ile kullanmış olabilirsiniz ama bu o eklentinin 1.6 için kodlandığı anlamına gelmez. Oysa 1.6 için kodlanmışsa zaten ileriki serilerde sorun çıkarmaz.

Alaca genel açıklama yapıyorum, doğrudan size değil. Konuyu okuyacak olanlar için önemli bu.

Alaca
19-01-2012, 15:31
Peki teşekkürler.